Currently there is a known disruption.
Incident Report for InterNetX
Resolved
This incident has been resolved.
Posted May 18, 2019 - 17:24 CEST
Investigating
Currently, we are experiencing a disruption. We have taken immediate action to resolve the issue. We apologize for any inconvenience and thank you for your understanding.
Posted May 18, 2019 - 17:07 CEST
This incident affected: Infrastructure (Data Center MUC).