Disruption - InterNetX Website
Incident Report for InterNetX
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 20, 2019 - 18:35 CEST
Update
We are continuing to investigate this issue.
Posted 3 months ago. Jul 20, 2019 - 18:08 CEST
Investigating
The InterNetX Website is currently experiencing a disruption. For this reason, the services are temporarily restricted. We have taken immediate action to resolve the issue. We apologize for any inconvenience and thank you for your understanding.
Posted 3 months ago. Jul 20, 2019 - 18:08 CEST
This incident affected: InterNetX Website.